Shop

My New Shop
MTS Creations

Subscribe to My YouTube Channel

Monday, October 1, 2012

XBMC There is no soundcard error

I upgraded my HTPC to Ubuntu 12.04 and it broke my XBMC from being able to run.
I searched high and low for the answer and never found one.  I fought with this to get my sound over HDMI when I first installed my HTPC.  My frustration was that the HTPC could play sounds via the default settings with this upgrade but XBMC would fail to start with the following error:
"There is no soundcard".

After much searching and two very late nights I was able to get it working by doing the following:

I'm posting this here and hope that this will either help me out in the future or will help some other Googler out there.

# aptitude install libcurl4-gnutls-dev
The following NEW packages will be installed:
  comerr-dev{a} krb5-multidev{a} libcurl4-gnutls-dev libgcrypt11-dev{a}
  libgnutls-dev{a} libgnutls-openssl27{a} libgnutlsxx27{a}
  libgpg-error-dev{a} libgssrpc4{a} libidn11-dev{a} libkadm5clnt-mit8{a}
  libkadm5srv-mit8{a} libkdb5-6{a} libkrb5-dev{a} libldap2-dev{a}
  libp11-kit-dev{a} librtmp-dev{ab} libtasn1-3-dev{a}
The following packages will be REMOVED:
  libutouch-evemu1{u} libutouch-frame1{u} libutouch-geis1{u}
  libutouch-grail1{u}
0 packages upgraded, 18 newly installed, 4 to remove and 0 not upgraded.
Need to get 3,974 kB of archives. After unpacking 10.4 MB will be used.
The following packages have unmet dependencies:
 librtmp-dev : Depends: librtmp0 (= 2.4~20110711.gitc28f1bab-1) but 2.4~20110711.gitc28f1bab-1ubuntu0~ppa4~lucid is installed.
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     libcurl4-gnutls-dev [Not Installed]               
2)     librtmp-dev [Not Installed]                       



Accept this solution? [Y/n/q/?] n
The following actions will resolve these dependencies:

     Downgrade the following packages:                                         
1)     librtmp0 [2.4~20110711.gitc28f1bab-1ubuntu0~ppa4~lucid (now) -> 2.4~20110



Accept this solution? [Y/n/q/?] Y
The following packages will be DOWNGRADED:
librtmp0
Post a Comment